Chapter 3. System Requirements

The library has been designed with goals of scalability and backward compatibility. As such, it supports a wide range of PHP installs. Note that not all features of the lib are available in every configuration.

The minimum supported PHP version is 4.2.

A compatibility layer is provided that allows the code to run on PHP 4.0.4pl1 and 4.1. Note that if you are stuck on those platforms, we suggest you to upgrade as soon as possible.

Automatic generation of xml-rpc methods from php functions is only supported with PHP version 5.0.3 and later (note that the lib will generate some warnings with PHP 5 in strict error reporting mode).

If you wish to use SSL or HTTP 1.1 to communicate with remote servers, you need the "curl" extension compiled into your PHP installation. This is available in PHP 4.0.2 and greater, although 4.0.6 has a bug preventing SSL working, and versions prior to 4.3.8 do not support streamlining multiple requests using HTTP Keep-Alive.

The "xmlrpc" native extension is not required to be compiled into your PHP installation, but if it is, there will be no interference with the operation of this library.